ParetoLogic Inc.

Support Center

EasyFileViewer requires Internet Explorer 8 or higher

EasyFileViewer will use connection settings from Internet Explorer 8.

You are required to have Internet Explorer 8, or a newer version of Internet Explorer installed on your computer. EasyFileViewer will use Internet Explorer 8 to open links contained within your files, or to connect to the internet for files that require it.

Did you find this article helpful?

Contact Us

customersupport@paretologic.com
http://assets1.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete